查看: 0|回复: 0
打印 上一主题 下一主题

通达信星星启动主图亚博国际娱乐试玩公式

[复制链接]

120

主题

120

帖子

368

积分

中级会员

Rank: 3Rank: 3

积分
368
跳转到指定楼层
楼主
亚博国际娱乐试玩
适用软件: 通达信
画图位置: 主图
未来函数: 无未来
更多交流: QQ群:50203834?公众号:金股典/jingudian?
B1:=MA(C,1);
B2:=SMA(SMA(SMA(B1,2,1),2,1),2,1);
SMA2:=MA(B2,3);
止损下限:IF(LLV(MA(B2,8),3)<>
IF(B2>SMA2,B2,DRAWNULL),COLORRED,LINETHICK4;
IF(B2<>
SNAKEA:HHV(MA(B2,1),13),COLORYELLOW;
VAR1A:=(2*CLOSE+HIGH+LOW)/4;
VAR2A:=MA(VAR1A,7);
VAR3A:=VAR2A-MA(VAR1A,7/2)<0;
VAR4A:=VAR2A-MA(VAR1A,7/2)>0;
VAR5A:=BARSLAST(VAR3A);
VAR6A:=0-BARSLAST(VAR4A);
VAR7A:=IF(VAR3A<=0,VAR5A,VAR6A);
STICKLINE(SNAKEA>B2 AND B2>SMA2,SNAKEA,B2,0,0),COLORBLUE;
STICKLINE(SNAKEA>SMA2 AND B2<>
VAR11A:=(CLOSE*2+HIGH+LOW)/4;
VAR21A:=EMA(VAR11A,13)-EMA(VAR11A,34);
VAR31A:=EMA(VAR21A,5);
VAR2:=((CLOSE > REF(CLOSE,1)) AND (CLOSE > REF(CLOSE,2)));
VAR3:=((REF(VAR2,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR4:=((REF(VAR3,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR5:=((REF(VAR4,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR6:=((REF(VAR5,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR7:=((REF(VAR6,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR8:=((REF(VAR7,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR9:=((REF(VAR8,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARA:=((REF(VAR9,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARB:=((REF(VARA,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARC:=((REF(VARB,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARD:=((REF(VARC,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARE:=((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,2)));
VARF:=((REF(VARE,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR10:=((REF(VARF,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR11:=((REF(VAR10,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR12:=((REF(VAR11,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR13:=((REF(VAR12,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR14:=((REF(VAR13,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR15:=((REF(VAR14,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR16:=((REF(VAR15,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR17:=((REF(VAR16,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR18:=((REF(VAR17,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR19:=((REF(VAR18,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR1B:=(REF((((((((((((VARE OR VARF) OR VAR10) OR VAR11) OR VAR12) OR VAR13) OR VAR14) OR VAR15) OR VAR16) OR VAR17) OR VAR18) OR VAR19),1) AND VAR2);
STICKLINE(VAR1B,O,O+(C-O)/3,2,0),COLOR10FFFF;
STICKLINE(VAR1B,O,O+(C-O)/3,1,0),COLOR00FFFF;
AA:=(REF((((((((((((VAR2 OR VAR3) OR VAR4) OR VAR5) OR VAR6) OR VAR7) OR VAR8) OR VAR9) OR VARA) OR VARB) OR VARC) OR VARD),1) AND VARE);
STICKLINE(AA,O,O+(C-O)/3,2,0),COLOR00EE00;
STICKLINE(AA,O,O+(C-O)/3,1,0),COLOR00FF00;
A13:=EMA(CLOSE,55);
A14:=MA(CLOSE,75);
A15:=EMA(A14,3);
A16:=EMA(A15,3);
A17:=(HIGH + LOW) / 5;
A18:=(MA(A17,4)) - (MA(A17,34));
A19:=CROSS(A18,0);
A20:=CROSS(0,A18);
A21:=BARSLAST(A19);
A22:=BARSLAST(A20);
A23:=REF(A19,1);
A24:=REF(A20,1);
A25:=BARSLAST(A23);
A26:=BARSLAST(A24);
A27:=IF((A25 < A26),(REF((HHV(HIGH,2)),A25)),(REF((LLV(LOW,2)),A26)));
A28:=(((REF(CLOSE,1)) <= (REF(A27,1))) AND (CLOSE > A27)) AND (A21 < A22);
A29:=(((REF(CLOSE,1)) >= (REF(A27,1))) AND (CLOSE < A27)) AND (A22 < A21);
A30:=A28 AND ((COUNT(A28,A21)) = 1);
A31:=A29 AND ((COUNT(A29,A22)) = 1);
A32:=A30 AND ((REF(BARSLAST(A31),1)) < (REF(BARSLAST(A30),1)));
A33:=A31 AND ((REF(BARSLAST(A31),1)) > (REF(BARSLAST(A30),1)));
DRAWTEXT(A32,SMA2*0.99,'←═≒∝'),COLORYELLOW;
AC:=AMOUNT/(VOL);
YY:=MA(AC,13);
LLL:=(C-YY)/YY*100;
MIDC := MA(CLOSE,22);
UPPERC:= MIDC + 2*STD(C,22);
LOWERC:= MIDC - 2*STD(C,22);
BBA:=(C-LOWERC)/(UPPERC-LOWERC);
BBC:=FORCAST(BBA,3);
LIFENGCYC:=(REF(LLL,1)<-15 AND REF(BBA,1)<0 AND LLL>REF(LLL,1));
STICKLINE(LIFENGCYC>0,C,O,2,0),COLOR10ABFF;
DRAWTEXT(LIFENGCYC>0,LOW*0.99,'☆'),COLORDD00DD;


您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

手机版| 感谢您的支持,本条链接自定义

Powered by Discuz! X3.1 ? 2001-2015 Comsenz Inc. GMT+8, 2019-9-3 16:04 , Processed in 0.031405 second(s), 11 queries , Eaccelerator On.

135股票论坛 ( 京ICP备14020393号-1 ) QQ
快速回复 返回顶部 返回列表